Posted by Nitin Pai
October 9th, 2008

Ftping files using FTPTARGET
Hi,
I am trying to ftp files using the ftptarget as opposed to using a ftp process.
I am using addattachment to ftp the file.
When I fire the code thru a button on a page, the file is sent to the
destination. But contains special characters and garbled.

If I use the same code on a AE and lauch it thru process scheduler,
it remains in NEW status and thye file never makes it.

Can you provide an example of how to accomplish this ?

Thanks for posting your question!

 

Since the file is actually being ftp’ed the process seems to be
working fine when you use the PeopleCode. Here are some
troubleshooting steps based on the information you have provided.

Are you sending plain text file?

How are you trying to access the file that was transferred?

Are you using the ViewAttachment function to view the file in PS?

Check web.xml to ensure that you have the correct mime-type.

<mime-mapping> <extension> DOC </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> Doc </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> DOc </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> DoC </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> dOc </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> dOC </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

<mime-mapping> <extension> doC </extension> <mime-type>
application/msword </mime-type> </mime-mapping>

Example code is available in PeopleBooks. Also, test using the
delivered FTP Test (PeopleTools > Utilities > Debug >
PeopleTools Test Utilities).

For AE option:

Try running the AE using the App Designer

Is the process scheduler running for the server option
you have selected?

Thanks

Nitin Pai

Comments (0)